Skip to main content
Welcome guest. | Register | Login | Post

Can't Install Subversion Completely

5 replies [Last post]
supermike's picture
Offline
Joined: 2006-02-17

Got a buddy at work who says he's installed SLES9, Apache2, and Subversion, but the subversion module in Apache2 won't load. I've just begun this problem and I can go back to him to ask more questions. Do you all have some good questions to ask him?

 

tbuitenh's picture
Offline
Joined: 2005-12-21
The "is it plugged in?" type

The "is it plugged in?" type question: did he uncomment or add the module in the apache configuration?

 

Don't laugh. This happens. 

supermike's picture
Offline
Joined: 2006-02-17
Before I read your post, TB,

Before I read your post, TB, here's what he posted to me: 

It was installed by someone else, so I'm not sure how it was done.  The problem appears to have begun when a user created a new repository.  When I found it, it was complaining of missing files.  I reloaded mod_dav, subversion, subversion-tools, and subversion-server from RPM and that didn't fix it.

I have now restored function to Subversion itself but the original web interface is missing. Also, I'm having to restore individual repositories as we go along.

 However, I posted your comment to him and I'll see what he says back.

 

supermike's picture
Offline
Joined: 2006-02-17
When I asked him, "Did you

When I asked him, "Did you uncomment or add the module in the apache configuration?" He replied:

Neither.  I reloaded the RPMs.

 

supermike's picture
Offline
Joined: 2006-02-17
This issue is resolved. The

This issue is resolved. The problem was that he had some stuff delivered to him with underscores in the name and the site wouldn't load. (I don't use Subversion so I don't know exactly what he means.) He renamed everything to a folder name without the underscore and the site loaded. Then, however, his styling on the page was broke. I told him to look for a CSS file and see if one of the web pages or conf files was referencing this CSS file by a different path. I suspected that this path was not the new path and that's why the thing was broke. So, two issues, and he resolved one and may be on the track to resolve the second.

 

libervisco's picture
Offline
Joined: 2006-05-04
Good to hear. About styling

Good to hear. About styling broken, in addition to having some url paths that are now broken in CSS he might also check his html files for references to his CSS files as those paths might also be broken now.

They should just be change to the new path (with new folder names), of course.

Just a thought.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.