Skip to main content
Welcome guest. | Register | Login | Post

how do I unlock the /etc/cups directory?

3 replies [Last post]
Offline
Joined: 2006-06-19

I've been trying to setup the new HP Deskjet D2430 printer - starting to bounce around for someone
who understands. I finally narrow the situation to where /etc/cups is locked because

- I can't update the CUPS driver via synaptic package manager (which runs as root) because it say

While installing package cups-1.2.4-5pclos2007:
error: unpacking of archive failed on file /etc/cups/cupsd.conf.default: cpio: rename failed - Operation not permitted
While installing package cups-drivers-2007-8pclos2007:
error: unpacking of archive failed on file /etc/cups/lxx74.convs: cpio: rename failed - Operation not permitted

and I know that root has read/write permission on /etc/cups/cupsd.conf.default & /etc/cups/lxx74.convs .

- I can't do anything with any of these file as root, i.e., in /etc/cups I tried using chmod and get

[root@localhost cups]# chmod +rw *
chmod: changing permissions of `classes.conf': Operation not permitted
chmod: changing permissions of `classes.conf.O': Operation not permitted
chmod: changing permissions of `command.types': Operation not permitted
chmod: changing permissions of `cupsd.conf': Operation not permitted
chmod: changing permissions of `cupsd.conf.default': Operation not permitted
chmod: changing permissions of `interfaces': Operation not permitted
chmod: changing permissions of `lpoptions': Operation not permitted
chmod: changing permissions of `lxx74.convs': Operation not permitted
chmod: changing permissions of `lxx74.types': Operation not permitted
chmod: changing permissions of `mime.convs': Operation not permitted
chmod: changing permissions of `mime.types': Operation not permitted
chmod: changing permissions of `ppd': Operation not permitted
chmod: changing permissions of `printers.conf': Operation not permitted
chmod: changing permissions of `printers.conf.O': Operation not permitted
chmod: changing permissions of `pstoraster.convs': Operation not permitted
chmod: changing permissions of `ssl': Operation not permitted

- I can't install the new printer via KDE control center, CUPS server,
PCC (PCLinxOS) control center, or the HPLIP setup utility - all because it
probably trying to write to the /etc/cups directory.

How can I unlock the CUPS directory? And how can I tell which application is
running so that I can kill it (don't want it running even if directory is unlocked)?

Sheng-Chieh

p.s. Using PCLinuxOS 2007, an RPM distro.

p.p.s. If you want to see earlier discussion about the printer problem, see

http://www.pclinuxos.com/index.php?option=com_smf&Itemid=58&topic=36806.0

tbuitenh's picture
Offline
Joined: 2005-12-21
Did you ever use the

Did you ever use the command chattr?

What is the output of the following commands?

ls -l /etc | grep cups
ls -l /etc/cups
lsattr /etc/ | grep cups
lsattr /etc/cups
Offline
Joined: 2006-06-19
problem solved - reinstalled OS

Thank you for replying. I decided to reinstall PCLinuxOS 2007
since the OS was acting slow (something else running???). Anyway,
the printer now works w/o a hitch and the PC is running at full
speed. The only drawback is it took me a 1.5 days because I messed
up the 1st installation and had to do it again.

Anyway, problem is solved.

Sheng-Chieh

tbuitenh's picture
Offline
Joined: 2005-12-21
Unexpected immutable files

Unexpected immutable files (I think a chattr must have happened, but that can't be verified anymore), slowness... that all seems rather fishy. Although you probably didn't get rootkitted, I do hope you used different passwords in your new install.

It's more likely your harddisk is bad, so do run filesystem checks more often than usual for the next while, for example weekly (here's how you can automate that).

If at some time in the future your system acts weird in inexplicable ways again, I recommend you scan it using chkrootkit. But, again, you probably didn't install software from shifty sources, and you probably don't run a ssh server with poor passwords (or something), so that probably wasn't the problem.

Comment viewing options