Skip to main content
Welcome guest. | Register | Login | Post

how to enable permissions on ubuntu 6.10

7 replies [Last post]
Offline
Joined: 2006-11-20

What do i have to do? I have to add a file and in gedit when i try to save its says i am not the owner and need permissions. im the owner.

AndrewB's picture
Offline
Joined: 2005-12-18
If it is not in your /home

If it is not in your /home directory you are not the owner. root is.
So do sudo gedit 'file.name'
You will be asked to enter your password
Now it should work

libervisco's picture
Offline
Joined: 2006-05-04
You can also make yourself

You can also make yourself the owner by getting superuser powers through sudo and just doing it like this:

sudo chown myusername file.name

Every user is in a group called "users" so you can change the file to be owned by that group as well:

sudo chgrp users file.name

Finally, if you want the file to be accessible to anyone (all permissions on) you do:

sudo chmod 777 file.name

Smiling

free-zombie's picture
Offline
Joined: 2006-03-08
777: nope
libervisco wrote:

sudo chmod 777 file.name

DON'T blindly copy that line.

In GNU/Linux, there are three types of permissions: read, write and execute. Read and write are obvious, execute means that you have the permission to run the file, if it's a program, or open the directory, if it's a directory. Setting this on a non-program can cause strange, potentially dangerous, behaviour of programs dealing with this file; especially file managers.

There are also three groups of people you can give these permissions to: the owning user, the owning group, and all others.

chmod can be given modes either in a cryptic numeric format, like above, or in a easier-to-understand format using the letters above, for example:

chmod u=rw,g+w,o-w file

stets the user's permissions to read&write, allows the group to write, and takes away writing permission from all others. If everyone (aall users) are to have/be given the same permissions, use "a" instead of "u", "g", or "o". Finally, here are some commonly found numeric codes and their meanings:

777 a=rwx
755 u=rwx,go=rx
666 a=rw
644 u=rw,go=r
700 u=rwx,go-rwx
600 u=rw,go-rwx

All popular file managers (including gnome's default nautilus) include a simple graphical interface to configure this.

a thing's picture
Offline
Joined: 2005-12-20
no

Bad idea. The OP is probably editing something in /etc/.

Offline
Joined: 2006-11-20
Ok

So this is what i am trying to do http://www.debianadmin.com/enable-wpa-wireless-access-point-in-ubuntu-linux.html
copied from above...
Procedure to enable WPA Wireless in Ubuntu
To update the source list run the following command
sudo apt-get
sudo apt-get install wpasupplicant
sudo apt-get install network-manager-gnome network-manager
sudo gedit /etc/network/interfaces
Comment out everything other than “lo” entries in that file and save the file

((when i try to create this file, permissions are denied. What would be the best way to get permissions w/o exposeing the other files.))
Create a file called /etc/default/wpasupplicant, add entry ENABLED=0 and save the file

sudo touch /etc/default/wpasupplicant
Reboot your system or use the following command
sudo /etc/init.d/dbus restart

Once you login back in to your machine you need to left-click the network manager icon in Gnome and select your wireless network It should prompts for password, type, etc and It will ask you to choose a password for your new “keyring”.

After enterring all the details my wireless network was connected and working fine you can see in the follwoing screen

libervisco's picture
Offline
Joined: 2006-05-04
You're right free-zombie,

You're right free-zombie, nice explanation. Smiling

fr0zenmon wrote:

((when i try to create this file, permissions are denied. What would be the best way to get permissions w/o exposeing the other files.))
Create a file called /etc/default/wpasupplicant, add entry ENABLED=0 and save the file

To create a file in /etc you need to log in as root or just temporarily get super powers. In command line that's done with the "sudo" command issues before the command that creates a file, like sudo nano /etc/default/wpasupplicant.

But if you do it graphically you can temporarily launch a file manager as root. You can do this by using a graphical "run command" box (available from menus usually) and typing this in it gksudo konqueror if you want to use konqueror or gksudo nautilus --no-desktop if you want to use nautilus (no desktop is so that it doesn't draw a nautilus desktop if you're not in GNOME for which that is usually used).

Then you just navigate to your file, open it up and edit it.

Another way is to just open gedit with superuser permissions: gksudo gedit.

Every time you issue a gksudo command before the program name you will be *graphically* prompted for your user password.

So that's a way of doing it without needing a terminal.

a thing's picture
Offline
Joined: 2005-12-20
su

sudo bash will get you a root shell for when you would otherwise be sudoing every command.

Better yet, use a distro that doesn't do this sudo stuff and uses su (anothing other than Ubuntu).

Comment viewing options