Skip to main content
Welcome guest. | Register | Login | Post

Installing automatix

3 replies [Last post]
Joined: 2006-12-04

These are the installing instructions for automatix. I followed them and totally messed up my computer. i am now copying my home directory to /usr/local/automatix. this line caused me to do so:
sudo cp -R * /usr/local/automatix/. Am i not supposed to be in a terminalwindow when i do this? my terminal opens in my homedir.. and i just started typing.

I hate linux and everything about it. Can anyone give me better instructions on how to install automatix??
The damage done to my cpu before i can handle this crap. gonna take lots of kubuntu reinstalls.........

# Licence GPL, see gpl.txt
# Written by arnieboy
# Automatix is copyright / trademarked by arnieboy
# Automatix is released under the Automatix license (Please refer to prop-license.txt)

gksudo -t "Installing Automatix" "rm -rf /usr/local/automatix"
sudo mkdir /usr/local/automatix
sudo cp conf/Automatix.desktop /usr/share/applications/
sudo cp -R * /usr/local/automatix/
sudo rm -rf /usr/bin/automatix
sudo ln -s /usr/local/automatix/Automatix /usr/bin/automatix
zenity --info --title "Automatix" --text $"Automatix has been installed in Applications-->System Tools !"

libervisco's picture
Joined: 2006-05-04
I never used automatix and

I never used automatix and I'm not sure how needed it really is if you can just use synaptic to install what you need. I think you can pretty much install anything you want without using automatix if you just add the right repository sources (which can easily be done with the new GUI in synaptic).

Of course, on kubuntu you use adept, which isn't as popular as synaptic. I would recommend installing Ubuntu (which comes with GNOME and synaptic and might be actually much easier on you).

About these instructions, they apparently don't mention a key thing. Where did you get them?

The key thing is to be in the automatix directory which I suppose you downloaded, when copying to /usr/local/automatix . If you downloaded automatix to /home/user/Desktop/Automatix then to go ther in terminal you do the following: cd /home/user/Desktop/Automatix replacing "user" with your username.

Then the instructions should work properly.

You've done nothing very damaging to the system by copying something from home to some other directory though. It's just *copying* and not deleting anything. You can't do any damage that way except if you overwrite something important, which didn't happen here.

Heh I thought automatix was supposed to be that easy thing making Ubuntu easy. If it's like this I wouldn't recommend it to new people at all.

Don't be discouraged though. Smiling It is you who is in control over what you do. If some program isn't very friendly it doesn't mean whole GNU/Linux OS is bad. In this case you really have alternative programs to automatix.


tbuitenh's picture
Joined: 2005-12-21
By the looks of it, those

By the looks of it, those are not installation instructions, but an installation script, in other words, a program. It probably had a name like "" or "INSTALL" or "install". It is similar to a setup.exe on windows.

What you did was reading, and then typing it line by line on the command line, right?

What you should have done is this:

cd directory/where/you/unpacked/automatix


The easiest way to fix your system is to simply install automatix in the way I described above, since that deletes the accidentally created /usr/local/automatix (see first line that doesn't start with a #).

Unless you freaked out and started deleting random stuff, there's no need to reinstall anything. Also, there is no need to hate linux. You're simply not used to it yet, but soon you will be.

libervisco's picture
Joined: 2006-05-04
Well said Taco. I am

Well said Taco. I am scratching my head over why I didn't realize the same thing even though I was wondering what does this #!/bin/bash thing do there. lol

I guess I need more sleep. Sticking out tongue


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.