Skip to main content
Welcome guest. | Register | Login | Post

Laggy scrolling in 3D mode (beryl)

8 replies [Last post]
libervisco's picture
Offline
Joined: 2006-05-04

Was talking with Teron on IRC a bit and got to the subject of Beryl which reminded me of my problem with it. While 3D desktop is not really a must-have for productivity, when everything works smooth with it except one thing I gotta wonder why that one thing doesn't.

The problematic thing with me, at least on Ubuntu Edgy is that scrolling in firefox, xchat and to a point other programs as well is quite laggy. It feels very slow. Actually just as I'm typing this I feel the lag in typing this text as well. It feels kind of heavy.

I'm wondering what could be a problem and if anyone experienced anything similar?

Thanks

free-zombie's picture
Offline
Joined: 2006-03-08
I don't see this, but an

I don't see this, but an explanation may be that all windows are first loaded into a temporary "screen", and then composited onto the actual display. traditionally, apps drew directly on screen — This copying image data to and fro might take more beef than the FX.

libervisco's picture
Offline
Joined: 2006-05-04
I see. There is more work

I see. There is more work to do before it can display the content. But not many seem to have this problem anyway though. I think I've got a good enough graphics card so it shouldn't be it. And something tells me it isn't about lack of memory either. Maybe 1.6 Ghz processor isn't enough for it?

What makes the most sense to me is that it is a software problem of some sort, a misconfiguration in xorg.conf maybe.. I guess I'll have a look at that.

a thing's picture
Offline
Joined: 2005-12-20
swappiness

Did you set your swappiness high?

libervisco's picture
Offline
Joined: 2006-05-04
I don't think it's

I don't think it's swappiness because I've been experiencing the same problem even before I set that up. The default swappiness is at 60 and I have it at 50 now.

Offline
Joined: 2005-12-20
Maybe the r300 driver in

Maybe the r300 driver in Xorg isnt up to it?

Although your card is quite strong, it might not be enough to run beryl at full speed.

Just an idea

Offline
Joined: 2005-12-20
Maybe the r300 driver in

Oops double post

But it gives me the oppurtunity to talk about RAM, that could be it too Smiling

libervisco's picture
Offline
Joined: 2006-05-04
Maybe it is the r300

Maybe it is the r300 driver, but I'd have to check with the proprietary driver to see if it's any better to be able to blame the free one. But it's not that important. Smiling

If that's the issues then I guess the newer versions of the r300 driver will fix it.

a thing's picture
Offline
Joined: 2005-12-20
change swappiness

Try setting swappiness to 0.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.