Skip to main content
Welcome guest. | Register | Login | Post

lost harddrive!

11 replies [Last post]
Offline
Joined: 2006-12-04

Hi!

I just installed kubuntu to my masterHD, problem is now i cant find my slaveHD.

In Systemsettings-> Advanced i can see it and i have "activated"(?) it. I mounted it to my /home directory, and after that i could find it. Couldnt read it though, permission denied. Im totally new to this and i dont know what im doing.. but thats probably obvious.

greatful for some tips

a thing's picture
Offline
Joined: 2005-12-20
need more information

1. What filesystem is the harddrive?
2. What OSs before have used the harddrive and how?
3. What options did you mount it with?
4. What user are you?

tbuitenh's picture
Offline
Joined: 2005-12-21
If that drive contains the

If that drive contains the contents of /home of a different linux distribution, the user IDs probably are wrong, for example on the first user "piano" might have number 101, and on the other number 102 or perhaps 501 or....
There's no easy solution for that, as far as I know.

If you're just trying to get to your files from windows, don't mount it to /home, but to one of the following, in this order of preference:

/mnt/windows
/mnt/[device name]
/mnt
/media/[device name]

Offline
Joined: 2006-12-04
supplyin the information
a thing wrote:

1. What filesystem is the harddrive?
2. What OSs before have used the harddrive and how?
3. What options did you mount it with?
4. What user are you?

1 NTFS
2 Win XP used it as an extra harddrive
3 mounted in /home/SDB1, type: ntfs (tried default setting(automatic))
4 Im the only user.. but i have to enter the admin-passw all the time..

I cannot see my windowspartition on my linuxhd either..

and i tried to mount it in as /media/SDB1 and as /mnt/sdb1

a thing's picture
Offline
Joined: 2005-12-20
partition layout

I think your problem might be that GNU/Linux is case-sensitive with filenames. "sdb" needs to be lowercase.

What's the partition layout of the harddrive? Run parted /dev/hdb and at the prompt enter "p".

This should be mounted in /media/.

For #4 above, I meant what user are you when you mount it and when you try to read it?

tbuitenh's picture
Offline
Joined: 2005-12-21
that should be parted

that should be parted /dev/sdb, right?

Offline
Joined: 2006-12-04
forgive me for being so

forgive me for being so slow here.. but i cant even run "parted /dev/hdb". i am completely useless in kubuntu it seems. I know there is only 1 partition on the harddrive (and it says so in systemsettings).
What user... my UID is 1000. my primary group is same as my username but i just changed it to "sudo".

It is now mounted as "/media/sdb1". I still get access denied.

"parted /dev/hdb" as well as "parted /dev/sdb" generates: WARNING you are not superuser. Watch out for permissions.

a thing's picture
Offline
Joined: 2005-12-20
sudo
piano wrote:

forgive me for being so slow here.. but i cant even run "parted /dev/hdb". i am completely useless in kubuntu it seems. I know there is only 1 partition on the harddrive (and it says so in systemsettings).

Okay then, if you know the layout then we don't need to see the output of parted.

piano wrote:

What user... my UID is 1000. my primary group is same as my username but i just changed it to "sudo".

The UID/GID is irrelevant if you're dealing with a filesystem that doesn't support it, like NTFS or FAT.

piano wrote:

It is now mounted as "/media/sdb1". I still get access denied.

Did you use sudo to mount /dev/sdb1?

Offline
Joined: 2006-12-04
thanks for helping. i

thanks for helping. i finally found something that solved it for me..

i deleted following line: #/dev/sdb1 /sdb1 ntfs uid=0,gid=0,auto,rw,users 0 0
and added: /dev/sdb1 /mnt/sdb1 ntfs umask=000,uid=0,gid=0,auto,rw,owner 0 0

in /etc/fstab. now im going for writingpermission.... anyone know how to solve that ? i guess its a parameter in the line i added that has to be changed. how does linux handle ntfs?? it seems i have alot to learn about root user.. i am unable to delete the folders ive created while trying to mount the disk in different places.Sad

tbuitenh's picture
Offline
Joined: 2005-12-21
Directories are deleted

Directories are deleted with "rmdir", not "rm". If rmdir complains about the directory not being empty, and you're sure you want to lose the contents, use "rm -r". If you somehow made read-only directories, you can delete those with "rm -rf". Be very careful when combining "rm -r" or "rm -rf" with a wildcard (*), or you may end up deleting your entire filesystem.

As far as I know ntfs is always read-only on linux, although there is some experimental work for write support. My information may be outdated, though.

free-zombie's picture
Offline
Joined: 2006-03-08
As far as I know , NTFS

As far as I know , NTFS write support is still incomplete and experimental; only a few operations are supported and those not by default.
captive ntfs is an alternate driver that supports writing.

Whistler's picture
Offline
Joined: 2006-01-03
...or install ntfsprogs and

...or install libfuse2, fuse-utils, libntfs8 & ntfsprogs and replace "ntfs" to "ntfs-fuse" in fstab file. You probably also need to add "fuse" to /etc/modules. This version of NTFS driver will support writing.

That Captive NTFS one will need MS' original driver which may cause legal problems to those who doesn't have valid Windows license.

Comment viewing options