Skip to main content
Welcome guest. | Register | Login | Post

printer: black ink doesn't work

4 replies [Last post]
Joined: 2006-06-19

To All:

The printer fails to print when using black ink. I tried

- cleaning the ink connection (metal dots between ink cartridge and printer) with
rubbing alcohol
- use a new black ink cartridge (I know it gives ink when cleaning it)
- force the printer to print black by specifying greyscale printing

When printing, I noted the printer goes zip, zip, zip (i.e., the ink cartridge
moves back and forth) and it sounds like it is printing, but nothing comes out.
The color cartridge works just fine although it is cheaper to use black ink.

What else should I be trying? How can I be sure that it is a hardware
malfunction and not anything else?

Fyi, I'm using a HP Deskjet D2430. In the past, the black ink worked just
fine. Any help would be appreciated.


Joined: 2006-03-28
Have recently any

Have recently any printing-related updated been pulled by your system? Like cups, gutenprint, foomatic, etc.
And if so, did the problem occur right after this, or maybe on the next reboot?

If any of those two questions can be answered with "no", I wouldn't think that it's system-related.

Do you have any other OS (maybe even Windows) on your box you could test your printer with? Or the possibility to connect your printer to another PC?

Joined: 2006-06-19
Thank for replying. No I

Thank for replying. No I didn't do anything (reinstall cups, etc). Another posting in another forum suggest not using
refurbished ink since manufactros wants you to buy their ink. And it was the first time I use refurbished black ink. So
I ordered manufactor HP 21 ink which should arrive this Wed. I'll keep you people posted on what happens.


p.s. I didn't try another PC, but that's a good idea - I'll try that if manufactor ink doesn't work.

Joined: 2006-06-19
The manufactor HP 21 ink

The manufactor HP 21 ink arrived earlier today. Now the
test page prints, but not a text file. I.e., I have

- test page prints using black ink
(with refurbished ink it didn't print)
- test page prints using color ink
- text file does NOT print black ink
- text file prints using color ink

I know this is true for both desktop and laptop. Now what?
I doubt it is the driver since color works. Any idea?

Moderator, I thought I posted this in "System tools, drivers and hardware". Can't figure out how it got into
"Programming". Can you easily move this?


libervisco's picture
Joined: 2006-05-04
It's possible that the text

It's possible that the text color in your text file is not exactly black or the program from which you're printing it isn't displaying it as exactly black, even if it appears black. This might explain why the black ink wont print it but color will. I'm not sure what else could it be. Perhaps you could test it with other text files and in different programs (viewers)..

shengchieh wrote:

Moderator, I thought I posted this in "System tools, drivers and hardware". Can't figure out how it got into
"Programming". Can you easily move this?

Weird, someone must've moved it. Anyway I moved it back to "System tools, drivers and hardware".


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.