Skip to main content
Welcome guest. | Register | Login | Post

Upgraded and now videos won't play!

2 replies [Last post]
Offline
Joined: 2008-04-14

A while ago I converted my friend to GNU/linux and he agreed to install it on his laptop. Recently, however, I believe it was when I was upgrading his system, video playback stopped working altogether. I have tried playing several (ogv, avi, etc) video formats in many players (including vlc, mplayer, xine, and more) with no results. I open a video, it loads just enough to see how long it is, and then the application quits. I have tried reinstalling various applications, upgrading, and everything else I could think of. Has this ever happened to anyone else? I can open the application by itself but when I try and play a movie it crashes. The only app that gives me any sort of an error message is SMPlayer:

/usr/bin/mplayer -noquiet -nofs -sub-fuzziness 1 -identify -slave -vo xv, -zoom -nokeepaspect -framedrop -input conf=/usr/share/smplayer/input.conf -stop-xscreensaver -wid 58720270 -monitorpixelaspect 1 -subfont-autoscale 1 -subfont-text-scale 5 -subcp ISO-8859-1 -subpos 100 -contrast 0 -brightness 0 -hue 0 -saturation 0 -nocache -osdlevel 0 -vf-add screenshot -channels 2 -af scaletempo /home/clanda/Movies/The Nightmare Before Christmas.avi

MPlayer dev-SVN-r25315
CPU: Intel(R) Celeron(R) M CPU 530 @ 1.73GHz (Family: 6, Model: 22, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Terminal type `unknown' is not defined.

Playing /home/clanda/Movies/The Nightmare Before Christmas.avi.
AVI file format detected.
ID_VIDEO_ID=0
[aviheader] Video stream found, -vid 0
ID_AUDIO_ID=1
[aviheader] Audio stream found, -aid 1
VIDEO: [XVID] 720x400 24bpp 25.000 fps 1201.4 kbps (146.7 kbyte/s)
ID_FILENAME=/home/clanda/Movies/The Nightmare Before Christmas.avi
ID_DEMUXER=avi
ID_VIDEO_FORMAT=XVID
ID_VIDEO_BITRATE=1201360
ID_VIDEO_WIDTH=720
ID_VIDEO_HEIGHT=400
ID_VIDEO_FPS=25.000
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=85
ID_AUDIO_BITRATE=128672
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
ID_LENGTH=4270.04
xscreensaver_disable: Could not find XScreenSaver window.
Opening video filter: [screenshot]

MPlayer interrupted by signal 11 in module: init_video_filters
ID_SIGNAL=11
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.

It said it exited with an error code 1. I can't make sense of the error message so if anyone has any ideas I'd greatly like to hear it. I did notice it said mplayer: no such file or directory so I tried reinstalling mplayer and even downgrading it but I still get the same error message. Thanks,

Mr. Todd

BTW the distro is Parsix GNU/linux if that makes a difference.

free-zombie's picture
Offline
Joined: 2006-03-08
Your video or audio driver

Your video or audio driver may have some problem...
Try these in a terminal window:
mplayer -ao null -vo xv "/home/clanda/Movies/The Nightmare Before Christmas.avi"
If this works, then the audio driver is the culprit.
mplayer -vo x11 "/home/clanda/Movies/The Nightmare Before Christmas.avi"
This doesn't use XVideo: playback will use more CPU, but should work with any driver. If this works, you can work around the problem by configuring video players to use "X11" video output. If this doesn't work, but the graphical interface does work in general, then you can be pretty sure that the video driver is innocent.
mplayer -vo gl "/home/clanda/Movies/The Nightmare Before Christmas.avi"
If this works, then you can work around the problem by configuring video players to use "OpenGL" video output. (contrary to pure X11, this is probably hardware-accelerated)

Offline
Joined: 2008-04-14
Thanks

The second optioned worked flawlessly!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.