Skip to main content
Welcome guest. | Register | Login | Post

USE flag problem

6 replies [Last post]
a thing's picture
Offline
Joined: 2005-12-20
arthur / # emerge -vp glibc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-libs/glibc-2.5  USE="nls -build -glibc-compat20 -glibc-omitfp -hardened (-multilib) (-nptl) (-nptlonly) -profile (-selinux)" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
arthur / # cat /etc/make.conf
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
USE="-X -opengl -gtk -gnome -kde -cups -doc minimal livecd jfs reiserfs xfs ntfs unicode nptl"
PORTDIR_OVERLAY="/usr/local/portage"
arthur / #

Why is -nptl being used?

libervisco: add .bb-code-block{overflow:auto} to the CSS ><

dylunio's picture
Offline
Joined: 2005-12-20
Have you tried putting

Have you tried putting "sys-libs/glibc ntpl" in /etc/portage/package.use? I don't know if this or why this would work, but I remember doing something like this when useing Bob P's stage 1/3 install.

a thing's picture
Offline
Joined: 2005-12-20
didn't work

Something's still forcing -nptl on it.

Muhaha! Post 666!

dylunio's picture
Offline
Joined: 2005-12-20
I have tried to replacate

I have tried to replacate your problem on both my Gentoo boxes, a thing, and failed. I used your USE flags too. So the only things I can suggest is to upgrade portage, I use the ~x86 branch, this may be the cause of your problems; also try adding "nptlonly" to your useflags and see if anything happens, but this is more of a shot in the dark.

dylunio

free-zombie's picture
Offline
Joined: 2006-03-08
ignore stuff in

ignore stuff in parentheses, it's unselectable.

a thing's picture
Offline
Joined: 2005-12-20
have to have it

That's impossible. I need glibc with nptl for glib.

free-zombie's picture
Offline
Joined: 2006-03-08
I thought that was the

I thought that was the default by now.

As a former gentoo amd64 user, I know that stuff in parantheses was often x86 only.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.