Skip to main content
Welcome guest. | Register | Login | Post

wireless depends on booting windows first

1 reply [Last post]
tbuitenh's picture
Offline
Joined: 2005-12-21

Previously, if I had switched off wireless in windows (to get rid of the annoying blinking light), it would stay switched off even after shutdown and booting linux. I had to boot windows to switch it on again, and then it would work in linux again too. Unfortunately this doesn't appear to be configurable throught the BIOS, so I hope windows doesn't break with the wireless switched off Sticking out tongue .

I now have a different problem: even when the wireless is switched on in windows, when cold booting linux I don't get wireless. I have to boot windows first, and then it will work, until I switch off the computer, then again I have to boot windows first.

I think the new problem has something to do with the firmware, but I'm not sure so I also mention the previously existing issue which I learned to live with.

Any ideas where I should start looking? Anyone who has had the same problem?

system: archlinux
kernel module: ipw2200
firmware: ipw2200-fw 3.0 (latest archlinux package)

tbuitenh's picture
Offline
Joined: 2005-12-21
The problem went away after

The problem went away after updating the kernel.

The archlinux blues: if you let kernel updates happen, you get problems, and if you prevent them, you also get problems. I suppose the firmware got updated and needed a newer kernel. Another package to prevent automatic updates of :/ .

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.