Skip to main content
Welcome guest. | Register | Login | Post

Wireless Internet Problem (linksys usb, rhyne pci, parsix gnu/linux, psk)

4 replies [Last post]
Offline
Joined: 2008-04-14

A couple weeks ago I installed Parsix GNU/linux on one of my desktop computers. Everything works flawlessly except for the wireless internet. I cannot connect to my protected network. Supposedly my network encryption type is PSK is that the same as WPA, WPA2, WEP, or am I missing something?? I am using a linksys usb adapter that worked flawlessly on winXP which was installed on it before. I also have a wireless card installed with PCI. Parsix only recognizes the rhyne one as an internet device. I have never had this problem before. It recognized the network but will not connect. I know I've typed in the security code right and I can connect to my neighbour's unprotected network (but I don't use it!!) but not mine. I've also tried Fedora 9 BETA instead of Parsix because fedora 9 is the only distro I've tried that recognizes my linksys adapter which i prefer to use over the rhyne pci card because it's faster. I have the same problem with it, though, too. It detects my network but will not work when i type in the password it just keeps asking or it over and over again. I have been trying to get this to work for weeks and spent hours and hours on google trying to find an answer.

I am not the one who set up the wireless encryption (my dad did) so I do not know any of the details other than the code and that it is PSK. I could connect to it from a laptop with Parsix installed without any hassle at all. It is a shared computer and if I can't get the Internet working on it my family will put windoze back on it. Please help!!!

If there's any thing else you need to know just ask! A quick reply would be greatly appreciated as well!

~Sweeney Todd

libervisco's picture
Offline
Joined: 2006-05-04
I am really sorry you

I am really sorry you didn't get a reply yet. I suppose nobody had similar experiences to share. I never used wireless connections myself, but since the problem here seems to be that it doesn't accept your password it reminds me of similar issues I had with my wired router. What usually solves this is a reset and then you can use the factory password.. But I might be completely off about this as this may be a different kind of password.

But anyway I guess it doesn't hurt to suggest to try and reset the modem (if possible) and use the factory password?

If it works on Windows, and the connection works even on GNU/Linux, yet you can't enter a password then provided that your password really is correct the problem must be in whatever software handles the encryption. Maybe it's just the GNU/Linux driver that isn't cooperating as it should, but I'm really guessing now.

What is the exact model of your Linksys USB or your Rhyne card?

Cheers

Offline
Joined: 2008-04-14
I wasn't sure if that was a

I wasn't sure if that was a very common problem among FOSS users, so it's not a huge dissappointment Sticking out tongue

However, maybe someone could enlighten me as to what this error code means? It's what Network Manager in Fedora 9 Beta says when I try to connect:

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device wlan0 ; Operation not supported.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0... failed.

Also, this is what my dad printed out when he set up the network at his house:

Your New Wireless Settings
Network Name (SSID):
linksys_SES_5731
Security: PSK
Passphrase: [removed; 16 char]

The exact model of the linksys USB wireless adapter is WUSB54GSv2

So, if anyone has any information or experience with that particular error message or wireless adapter or wireless settings, I would very much like to know.

Thanks
~Sweeney Todd

free-zombie's picture
Offline
Joined: 2006-03-08
"PSK" stands for "private

"PSK" stands for "private shared key" AFAIK, and the acronym I only know from "WPA-PSK". WLAN is a bit of a problem at the moment, as in many cases the free drivers either don't exist (not the case for you) or are below par (possibly the case here). I myself have a Ralink rt2561, for which the new driver (the manufacturer supplied a working driver that didn't play well with the standard tools) didn't, last time I tried, work with WPA, but works fine with WEP or no encryption.

Judging from the error messages, I think the driver might use some non-standard configuration file or interface that NetworkManager doesn't support. Though, if it comes with the distribution, it should really play well with standard kernel interfaces...