Skip to main content
Welcome guest. | Register | Login | Post

X crashes when no usb mouse is connected

5 replies [Last post]
tbuitenh's picture
Offline
Joined: 2005-12-21

When I have a usb mouse connected to my laptop, everything works fine, including the touchpad. When my usb mouse is not connected, X will crash. It seems the crash is caused by using the touchpad, but I'm not really sure of that.

What's worse, it's not only X that crashes, it takes the whole OS with it, and it's not so friendly to crash in a way in which I can see some text error messages flash by or something. It just freezes, and the only way to thaw it is to switch off the laptop and switch it on again.

Here's my (very normal I would think) xorg.conf, with all the comment junk removed:

Section "Module"
    Load        "dbe"   # Double buffer extension
#    Load "synaptics"
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "freetype"
    Load       "glx"
    Load       "dri"
EndSection

Section "Files"
    FontPath   "/usr/share/fonts/misc"
    FontPath   "/usr/share/fonts/100dpi:unscaled"
    FontPath   "/usr/share/fonts/75dpi:unscaled"
    FontPath   "/usr/share/fonts/TTF"
    FontPath   "/usr/share/fonts/Type1"
EndSection

Section "ServerFlags"
EndSection

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc104"
    Option "XkbLayout"  "us"
EndSection

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "Auto" # Auto detect
    Option "Device"      "/dev/input/mice"
    Option "ZAxisMapping"   "4 5 6 7"
    Option "Emulate3Buttons"
EndSection

Section "Monitor"
    Identifier  "acer lcd"
    HorizSync   31.5 - 48.5
    VertRefresh 50-70
EndSection

Section "Device"
    Identifier  "Standard VGA"
    VendorName  "Unknown"
    BoardName   "Unknown"
    Driver     "vga"
EndSection

Section "Device"
    Identifier  "mobility radeon 9700"
    Driver      "radeon"
    VideoRam    65536
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "mobility radeon 9700"
    Monitor     "acer lcd"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

Section "DRI"
    Mode 0666
EndSection

That's right, I'm not even using the synaptics module! What could be so fatally wrong with this simple configuration? And why does it only happen when the external mouse is not connected?

Note this problem exists for quite a while already, I was hoping it would go away with the next archlinux update, didn't have time to update for a few weeks, and now I updated today (both X server and kernel got updated) it's not gone Sad .

tbuitenh's picture
Offline
Joined: 2005-12-21
If I could somehow disable

If I could somehow disable the touchpad completely - so no external mouse will mean a stuck cursor instead of a crash - that would be enough of a solution for me.

Alternatively, does anyone have any hints for what I need to look at apart from the X configuration when I have mouse problems?

tbuitenh's picture
Offline
Joined: 2005-12-21
To prevent double work,

To prevent double work, here's the arch linux forums thread about the same problem. No solution found yet, please help!

libervisco's picture
Offline
Joined: 2006-05-04
I'm sorry to see nobody

I'm sorry to see nobody help with this yet. I suppose it's a rather exotic issue. Sad

I looked it over and never having a laptop I really can't say much.. I can only suggest, if you didn't already and for the sake of eliminating a few possibilities, to try boot your laptop off of some other live cd distros (ubuntu or such) and see how it acts. Perhaps it's a hardware issue (I'd hope not, but just in case)..

If it's really happening just in Arch and yet Xorg configuration is OK (I am assuming you didn't actually change it when this started happening so it isn't really a culprit) some bug must have crept in the kernel or whatever else is anyhow involved in managing the touchpad.

Perhaps it may be time to switch a distro then. :S

tbuitenh's picture
Offline
Joined: 2005-12-21
I do still have to try a

I do still have to try a livecd... there's gotta be one of those around this room somewhere... I *think* it will work just fine with a livecd, but that won't rule out many possibilities since both the software versions and configuration will be different, and if the problem exists with a livecd too that doesn't prove it's a hardware issue.

Someone at the archlinux forums pointed out that X makes log files, I'll trigger a crash and see what gets written to those first.

tbuitenh's picture
Offline
Joined: 2005-12-21
Here's another symptom: at

Here's another symptom: at the end of /var/log/Xorg.0.log after a crash (or probably Xorg.0.log.old if you use a graphical login screen):

tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
...

Apparently this is a GPU lockup. The solution is to disable DRI. I have no idea why having an extra mouse would prevent a GPU lockup, perhaps it slightly changes some timing somewhere.

Of course the REAL solution is to use the stable version of Xorg instead of the prerelease that archlinux provides.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.